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1. Create a Project 

 
By creating a project, you can browse across files. 

1.  Create a project Click  File→ New Project 

Location:  The folder where you wish to create the project file 

Project Name:  Name of the project file you wish to create. The project file will have the extension  .sur or .pur  

2.  If source files or header files have 
extensions other than *.c,  *.cpp,  *.h 

 

3.  Add source files and header files to the 
project 

Click   < Add Files > in Project Management Menu. 

Select the radio button "All Source Files" and Click  

Or Select files from the displayed list and click  

4.  Set the Include-Path-Sequence Click  < Include Path > in the Project Management Menu. 

It is not enough to simply add the header files to the project… 

− Select the “Include subfolders” box if header files are #included from the sub-folders too. 

5.  Parse All Files Click  < Parse All > in the Project Management Menu. 

6.  After parsing, check for Missing header files. Click  < Missing Includes > in the Project Management Menu 

If header files are missing, some type names may remain undefined and result in syntax errors. 

Syntax errors are displayed in pink color. 

If a syntax error involves a function-header (start of a function), then the function is not recognized and hence 

its flowchart is not available. 

7.  If any header files are missing: Add the necessary folders to the Include-Path-Sequence so that Crystal Flow can find the header files 

8.  After adding folders to the Include-Path-
Sequence: 

Reparse All Files by clicking  < Reparse All > in the Project Management Menu. 
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2. Dummy-Header File & Language Extensions 

1.  If your code contains non-ANSI C keywords: Use the dummy-header-file or the Language extensions to handle non-ANSI C keywords:  

 
Language extensions can be supported by means of either the dummy-header file or the language extensions 

card of the Options menu:  

Let us start with an example:  

__usert TBool find_ele( int *arr_p, int amax ) 

{ 

... 

}  

a)  Since ANSI C does not recognize __usert and TBool, you can add a declaration or #define for 

__usert and TBool in the Project Dummy Header file. Crystal REVS automatically #includes the 

Project Dummy Header file at the beginning of each file in the project.  

You can open the Project Dummy Header file from the "Project" pull-down menu or the "Prj Files" 

pane of the Browse Window.  

The Project Dummy Header file is like any other header file, you can edit it and save it. You can 

#include other files in it.  

#ifndef dummy_header_is_included_once 

#define dummy_header_is_included_once 1  

# define __usert  

typedef int TBool;  

#endif  

After you modify the dummy-header file, save it and Reparse All files. 

b)  Or you can use the Language Extensions card of the Options Menu. You can add a new 

scheme. Enter TBool in the "Types" and click . Similarly add __usert to the "Others" 

column.  

(Adding to the "Others" column has the same effect as #define __usert as shown above.)  

Both Project Dummy Header file and Options settings are saved on a per-project-basis.  
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3. Flowchart 

1.  Create a Flowchart Place the cursor anywhere in a function.   Click < Create Flowchart >  in the toolbar or press   

2.  View Flowchart and Code side-by-side Click on the  button below the window to display the code and flowchart side by side. 

 Highlight code in File window Click in the right-half of a flowchart symbol to highlight the corresponding code in the File window. 

 Scroll highlighted code in File window While the corresponding code is highlighted, click the scroll icons   or   in the flowchart toolbar 

3.  View Type Information a. Click in the left half of a flowchart symbol. 

b. Hover the mouse pointer over an object name in flowchart symbol. 

4.  View the conditions that need to be true  To view the conditions that need to be true in order to reach the current flowchart symbol: 

- Select < Show/Hide Outer Window >  in the toolbar at the top of the condensed-flowchart. 

In the sequence of conditions that are displayed below the condensed flowchart  

- Click on any condition in the sequence to go to the corresponding symbol. 

5.  Flowchart Toolbar Roll the mouse pointer over toolbar buttons to gain familiarity 

6.  High-level Symbols A high-level symbol is indicated by a thick purple border. 

 View Code Coverage Click in the left part of a high level symbol to view the code covered by it.  

 Expand a high-level symbol Double click on a high-level symbol to expand it. 

 Collapse symbols at the current level Double-click in the right-half of a low-level symbol to collapse all symbols at that level 

7.  Level-n-flowcharts Click   , ,  or  so that the condensed view shows the "right" amount of detail; 
neither oversimplified nor too crowded. 

Click the < Create an optimal Flowchart >  to view the default level. 

8.  Divide and Conquer For long functions, get the whole view of the function by seeing it’s top level flowchart. 

Then view the flowcharts of it’s major parts such as large switch-statements, loops, etc 
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9.  Create a sub-flowchart Click  , the 2
nd
 icon from the top in the Flowchart window toolbar  

- when a "switch" symbol in the flowchart is selected, the  icon is called "Create Current Switch 
Flowchart"… similarly, for a "while" symbol, a "for" symbol etc. 

 Create a switch-flowchart 

(Similarly create the flowcahrt of a while-
loop, if-else, for-loop etc.) 

a. Place the cursor on a switch statement in File window;   

click  Flowchart → Create Code Flowchart of → switch 

b.    Click on a switch symbol in the flowchart;  

click  < Create Current Switch Flowchart >  i.e. the 2
nd
 icon in the toolbar 

 Create a deeper sub-flowchart 
In current sub-flowchart, select the "right" level of detail with  , ,  then create a sub-flowchart 

as needed 

 Go back to parent flowchart Click  in the toolbar of the Flowchart window 

 Go back to sub-flowchart Click  in the toolbar of the Flowchart window 

10.  Go to the flowchart of a Called function Right-click in a symbol that contains a function-call.  

Click < Create Flowchart for function call > then click the ‘function name’.  

Use < Change mode >  near the bottom of the toolbar to go back and forth between the caller-

flowchart and called-flowchart 

11.  Expand function-calls in a flowchart First, you need to create an expandable flowchart as described below. 

 Create an expandable Flowchart Place the cursor anywhere in the function. 

Click the pull-down menu CallFlow→Expand Calls in a Full Function Flowchart 

 Expand a function-call The presence of a function-call is indicated by the  above the symbol. 

- Double-click on a symbol that contains a function call.  

The expansion is inserted just before the function call. 

 Collapse an expansion Double-click on the start symbol of an expansion 

12.  Transparent Flowchart Window When the flowchart window overlaps the File window, you can see the source lines covered by 
the flowchart: 

- Click   in the flowchart window toolbar to make the flowchart window transparent. 
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13.  Navigating in Flowchart  

 Arrow-keys and the Home key - Press the arrow keys to walk through the flowchart.  Press the Home key to go to the start of flowchart 

 Hand icon to drag and move - Click  to select it.   Now you can click-and-drag to move in the flowchart. 

14.  Highlight one or more connections  

 Highlight a Flowchart connection Click on a connection to highlight it. 

 All connections that arrive at a 
statement 

Click on the input of a flowchart symbol.  All paths that go into the input are highlighted. 

 All paths that leave a high-level symbol Click on the output of a symbol. All paths going out of that output are highlighted. 

 Highlight another connection To highlight another connection while retaining the current highlighting, press  and then click on a 
connection to highlight it. 

15.  Visual distinction in a monotonous flowchart Please view the Help contents. (Flowcharts->Basic Operations->How to add…) 

16.  Text search in a flowchart - When in a flowchart, click  in the main toolbar. 

- Enter the “text” to be searched. 

- Click < Mark All >  - the symbols with the matching text are highlighter. 

- Use  and  to view the symbols containing the matching strings 

17.  Customize 
 

 Labelling of True and False branches You can customize the text displayed on the YES and NO paths of an “if statement.”. 

- Click Flowchart →Customize to view the options menu 

 Flowchart  Settings The flowchart  is controlled and customized by several flowchart-settings.  

- Click < Flowchart Settings >  in the flowchart toolbar to modify settings. 

 Flowchart Appearance Click Flowchart →Appearance to customize the look and appearance of the flowchart 

 Customize Flowchart window To customize the fonts, font-size, toolbar position, connection and symbol line thickness, etc: 

- Click Flowchart →Customize to view the options menu 
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 Customize shapes for system-calls Symbol shapes for function calls can be customized.  To customize shapes: 

- Click Flowchart →Customize Shapes to view the Associate Function Names with Shapes dialog.  

18.  Types of flowcharts 
 

 Code Flowchart - Click  < Change mode > in the flowchart toolbar and then select < Switch to Code Flowchart >  

 Comment Flowchart Place the cursor within the function 

- Click the pull-down menu  Flowchart → Create Comment Flowchart of → current function 

 Code + Comment Flowchart - Click  < Change mode > and then select < Switch to Code + Comment Flowchart > 

19.  Special Comments In a comment flowchart, you can replace a loop, a switch or a few statements with an overall comment. 

Please view the Help contents. (Flowcharts->Special Comments…) 

20.  Print a flowchart 
 

 Print preview Right-click in the flowchart window;   Click < Print Preview > in the pop-up menu. 

In the Print preview window, click the "Tile Pages" button to view multiple pages or a single page. 

 Sizing for print a.    Click "Zoom In" or "Zoom Out" in the flowchart toolbar then view the Print preview. 

b.    You can print the whole flowchart on a single page: 

- Right-click in the flowchart window;  Click  Print;  Select "Flowchart in Single Page" 

- Use the pull-down menu  File->Page Setup->Flowchart 

21.  Export Flowchart 
 

 Export flowchart -
 .jpg, .bmp, .html 

With the flowchart window active,  use the pull-down menu Flowchart→Export Flowchart Image 

Similarly, you can click-and-drag to select a part of the flowchart and export it as a bitmap. 

 Export flowchart to Visio Right-click in the flowchart window;  then click "Visio Export" 

With the flowchart window active,  use the pull-down menu Flowchart→ Visio Export 
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4. Trees – Call, Caller, File, Base, Derived, Project, Relationship 

1. Call Tree Place the cursor within a function.    Click  in the toolbar 

2. Caller Tree Place the cursor on a function name.    Click  in the toolbar 

3. File Call Tree The File Call tree shows the relationship between all functions in the current file.  

It helps you to get started with understanding and reviewing the file. 

− Click Tree→Create File Call Tree 

4. File Tree The file-tree shows files that are #included in the current file.  

− Click    in the main toolbar 

5. Data Dependency Tree Place the cursor on any data-object.  

− Click <Create Data Dependency Tree>  icon in the toolbar. 

6. Base Class Tree A base class tree is a tree of the current class and it’s base classes.  

− Place the cursor on a class name.     

− Right click, then click Base Classes. 

7. Derived Class Tree A derived class tree is a tree of the current class and it’s derived classes. 

− Place the cursor on a class name.     

− Right click, then, click Derived Classes 

8. Include By Tree The Include by Tree shows files that include the current file.  

− Place the cursor anywhere in the current file.    

− Click the Tree→Create Include By Tree 

9. Project Call Tree A Project Call Tree is the Call Tree of all root functions of a project. 

− Make sure that all files in the Project have been parsed (in Project Management menu). 

− Click Tree Project Call Tree 

10. Project File Tree A Project File Tree is a file tree of all project files.  The files not included by any file are at the first level.  

− Make sure that all files in the Project have been parsed (in Project Management menu). 

− Click Tree→Create Project File Tree  
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11. Project Class Tree Make sure that all files in the Project have been parsed (in Project Management menu). 

− Click Tree→Create Project Classes Or press  +   

12. File Relationship Tree of the current file A File Relationship Tree shows the files from which the current file uses Globals or Functions. 

− Place the cursor anywhere in the current file. 

− Click the Tree→Create File Relationship Tree 

13. Class Relationship Tree of the current class A Class Relationship Tree displays the classes which use the Data Members or Function members of the 
current class. Such classes should not be in the hierarchy of the current class. 

− Place the cursor on a class name. 

− Click Tree→Class Relationship Tree 
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5. Tree Operations 

1. Order tree-nodes by name Click  < Tree Settings >   in the tree toolbar.    In the popup, click  Call Tree nodes sorting�By Name 

Alternatively, you can use the pull-down menu  Tree�Settings… 

2. Order tree nodes by call-occurrence Click  in the tree toolbar.   In the popup, click Call Tree nodes sorting�By Occurrence�Show All 
Occurrences 

To order by the first call of a function and hide its other calls,  click <Show First Occurrence> in the above. 

3. Show library functions,  

undefined functions etc. 

Click  .    In the popup, turn the desired item On or Off. 

4. Expand the whole tree To fully expand the sub-tree under the current node,  

Right click anywhere in the Tree window;    Click < Expand Full > 

 Expand once To keep the tree compact, tree nodes which have been expanded once are not expanded again. 

- Click    in the tree toolbar.    Turn < Expand Once > ON. 

5. Node Prefixes - P - indicates that the node is a pointer to a function.  

- L - indicates that it is a library function/library file.  

- A - indicates that this function was assigned to the pointer-to-function or used to initialize a pointer to 

function in a declaration  

- * -  indicates that the function is recursive  

- X - indicates that the function is declared but not defined.  

- ? - indicates that the function is neither declared nor defined 

6. Go to function-call A single click on a node in the Call-Tree: 

− moves the cursor to the first call of the function after the current cursor position.  

− Subsequent clicks will move the cursor to the next call of the function in the current function 

7. Go to function-definition In a Call-tree or Caller Tree, double click on a node to go to the definition of that function. 

8. Type information of current node To view the prototype (or the full declaration) of the function in the current node,  

Right click anywhere in the tree window.;    Click < Type Information > in the popup menu. 
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9. Search in tree  

 Using the Search box in the search 
toolbar 

With the Tree window active, use the drop-down list in the Search Panel in the main tool bar. 
It will show all the functions names in the tree.  

− Enter a first few characters of the desired function.  

− When the desired function is visible in the list, double click and enter it in the search panel.  

− Press the enter key. 

 Using the Search icons in the main 
toolbar 

Click  to go to the next occurrence of the current node in the tree.  

Click  to go to the previous occurrence of the current node in the tree. 

10. View call-sequence a) Call-path from the root to the current node.    

b) Call-paths from root to all occurrences of the current node. 

 Call-sequence to current node Right-click, then click < Show Path >. 

 View all call-sequences  Right-click, then click < Show All Paths >. 

 Show whole tree  

(call-sequence nodes are highlighted) 

After viewing a call-sequence,  

− To view the whole tree again, right-click, then click <Show Whole Tree>  

− To turn Off highlighting of the sequence-nodes, right-click, then click <Unmark Path> 

11. Navigating in the tree  

 Use the Home key, Arrow keys Press  to view the root of a fairly long tree 

Press   to move downwards at the same level or to the child-node 

Press  to move upwards at the same level or to the parent node 

Press  to expand the sub-tree of the current node and move to it’s first child. 

Press  to collapse the current sub-tree and go to the parent of the current node. 

Also try the  +  ,  +   and the  +  key combinations. 

 Go to parent node Click  in the toolbar or press the  +   key combination. 
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 Go back to previous / Go to next - Click  in the tree. Alternately, you can press  +  key combinations. When you click this icon 
repeatedly, you will reach the first node that was visited. 

- Click in the tree. Alternately, you can press  +  key combinations. When you click this icon 
repeatedly, you will reach the last node visited. 

12. Mark / hide  

 Marking and unmarking nodes To mark a node:    Select the node by clicking it;    Click in the toolbar 

To unmark a node:    Select the node by clicking it;    Right click, then click < Unmark > 

 Go to a marked node up/down Click    or    to go upward or downward to a marked node. 

 Hiding and unhiding nodes To hide an insignificant node,  

− Select the node you wish to hide.    Click on   in the toolbar 

To unhide a hidden node, 

− Click  on the toolbar and select the node you wish to unhide     Click on   in the toolbar 

13. Tree Settings Click on   in the toolbar to change the settings.    For details, refer to Help. 

14. Tree Appearance Click Tree→Appearance to customize the look and appearance of the flowchart 

15. Customize the Tree Window To customize the fonts, font-size, toolbar position, etc,    Click Tree→Customize. 

16. Export Tree  

 Export as .jpg, .bmp or .html To Export a part of the tree as a Bitmap: 

- Select the part of the flowchart to be exported by drag and select. 

- In the flowchart window, click Tree→ Export Tree Image →Selected 

To Export a tree as a Bitmap: 

- In the flowchart window, click Tree→Export Tree Image→Whole. 
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 Export as a .txt file To Export a tree as a text file: 

- In the tree window, click Tree→Export Tree Image→Whole. 

- After specifying the filename, in the Export Image As dialog, select the Files of type – to TXT 
files, and, then click < Export  > 

17. Create flowchart of the current node - Click  on the Tree toolbar  

18. Create CallFlow of the current node - Click  on the Tree toolbar  
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6. Browse Window 

1. Browse Window The various cards in the Browse Window will help you to browse at the: 

- project-level 

- file level 

- function level 

You can print the contents of the Browse Window or export as-a-text-file. 

2. Project Files <Prj Files> card In the Prj Files card, 

- Try double-click  and  right-click  on a file name 

- Right click on the root node to add files to the project, edit the include path sequence 

3. Project Browse <Prj Browse> card In Prj Browse, you can view the list of all: 

- functions, root functions,  recursive functions, conditioned-out functions,   globals, structs and unions, etc. 

Try double-click and right-click on any node. 

 Go to a Function’s definition - Double-click on a function name 

 View Recursive functions - Click on "+" to expand the "Recursive Functions" node. 

 Print the Tree or Export as a text file - Right-click on the root node;     Click on "Print" or Click on "Export To Text File"  

4. Project Report <Prj Report> card In Prj Report, you can view the file-by-file list of: 

- functions, root functions, unused functions, globals, structs and unions, enums 

- #defines, typenames,   Files #included,   unused globals, unused locals 

 View / Hide Specific items As an example, to view only the Globals in each file: 

- Right-click on the root node;    Click  on  Expand / Collapse Group�Globals 

To hide all other groups: 

− Right-click on the root node;    Click  on  Expand / Collapse Group�Globals 

 Print the Tree or Export as a text file - Right-click on the root node;     Click on "Print" or Click on "Export To Text File"  
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5. Switch To  − Double-click on a Recently Visited Function name 

− Double-click on an Open file name – to go to that window 

6. Outline View the outline of the current file. 

Go to any function, comment, #include, #ifdef etc.in the file by clicking in the Outline window. 

 List of  functions in the current file − Click on icon to view the list of functions in the file.   Double-click on a function to go to its definition 

− Click on other icons to select/deselect them. 

 Use Outline to walk through the file In Options�Environment�Browse Window,  select "Go to Occurrence on Single Click in Outline" 

− Click and select any item in the Outline card of the Browse Window. 

− Simply press the  key on the keyboard to go to the next item and thus walk through the fie. 

 View the #if, #ifdef, etc affect When you select an #ifdef, etc. in the list in the Outline card: 

− the lower panel shows the scope of the #ifdef and the items that are affected by it. 

7. File Report View a function and data summary of the current file.    Double-click to go to the corresponding line in the file. 

8. Flowchart The flowchart card displays  a condensed view of the Flowchart. 

 View the conditions that must be true Select < Show/Hide Outer Window >  in the toolbar to display the list of conditions enclosing the current 
flowchart symbol. 

9. Function’s outline The Function Outline / Area Outline display’s a skeletal outline of the current function or Class/Namespace.  It is 
useful for navigating in long areas. 

You can also view the sequence of all the #if, #ifdef, #else etc. in the file. 

 View the conditions that must be true 
In the lower part you can see the sequence of conditions - if, else, for, while etc. that must be true in order to 
reach the current line in the File window 

10. Function Properties/Area Properties View and go to: 

- Callers of the current function,        Functions called by the current function 

- Structures, #defines, globals etc. used by the current function 

Try single-click  and  double-click on the nodes. 

 Callers of the current funciton Expand the "Called By " node 

- A double-click on a function name will take you to the definition of that function. 
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7. Navigation 

1. Display Quick Buttons Click < Make the File Window Taller >  icon at the bottom of the Crystal Window. 

Or click pull-down menu  View�Tall Window 

2. Outer indent Click   to move the cursor to the outer indent level.  

3. Skip Deeper Indents Click any one -   .     

For example: 

- to go from a function to the previous / next function 

- skip the body of a loop 

- to go from a case to the previous / next case 

4. Sentence wise navigation Click  or  buttons to go to the next or previous sentence. 

You can skip a declaration with a very long initializer – with just a  single click. 

5. Function wise navigation 
Click   or   to go to the next or previous function 

6. Go back and Go forward 
To go back to the just previous position - you were editing at – click   

To go back to the point where you clicked the previous < Go Back >, click  

7. Pop Context Click  to return to the file-and-location preceding the most recent browse operation. 

8. Go to Modified lines Visit the lines of code that were modified by you by clicking  and .  

Crystal REVS for C and C++ remembers modified lines even across sessions. 

9. Go to Marked lines To visit the marked lines: click  and . 

10. Scroll half a page - Click  to bring the current line to the top of the screen. 

- Click  to bring the current line to the middle of the screen. 

- Click  to bring the current line to the bottom of the screen. 
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11. Next or Previous word To search for a whole word: 

- Place the cursor on a function name or identifier 

- Click the  or  

12. Next or Previous object To search for an object as per the C/C++ scope rules: 

- Place the cursor on the object  

- Click  or   

13. Find and Replace  

 Plain Text  Search / Object Search You can use the search-panel in the search toolbar or the Find dialog. 

 Lexical Search To search for a sequence of tokens as per C/C++ lexical rules  

(ignore differences in amount of white space, match across line boundaries) 

- Click the  in the search toolbar or press  +  to bring the Find dialog. 

- Set the mode to Lexical Search 

- Enter the search string in the "Search for" panel. 

- Set the Scope – File/Function/Selected text. 

- Click < Find > 

 Regular Expression Search To search a regular expression  

- Click  in the search toolbar or press  +   to bring the Find dialog. 

- Set the mode to Regular Expression Search 

- Enter the regular expression in the "Search for" panel. 

- Set the Scope – File/Function/Selected text. 

- Click < Find >  
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 Mark Lines To mark all lines that contain a matching string 

- Click  in the search toolbar or press  +   to bring the Find dialog. 

- Set the search mode 

- Enter the search string 

- Set the Scope – File/Function/Selected text. 

- Click < Mark All >. 

14. Find in Files (GREP) 
Press  +  or click on the in the search toolbar to display the Find in Files dialog. 

- Set the Search Mode: Text, Lexical, Regular Expression, Object, Modified Object. 

- Specify the search string into “Search For ” panel. 

- Specify the target folders: You can select one of CURRENT FILE, DESKTOP FILES, or PROJECT FILES, 
or, use the Browse button and select the folder. 

- Click < Perform > button. 

The search results are displayed in the output window under the GREP card. 

You can view the results as a list or as a tree with  

 Where modified occurrences Modified occurrences of an object are those occurrences where the object is being used on the left hand side of 

an assignment, or, contents of the object are being modified by passing the object as a reference to a function, 

or, the object is being subjected to pre or post increment or decrements. 

To find all such occurrences of an object in the project 

- Place the cursor on the desired identifier.  

- Right-click, then click “Where Modified Occurrences”. 

 GREP and Replace In the output window, in the GREP card 

- Click  to bring the Replace dialog. 

- Specify the Replace By text. 

- Check/Uncheck the desired File Modification items. 

- Specify one of the Replace Occurrences option – Current”, “All in current file” and “In all files”. 

- Click < Replace >. 
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15. Go to Definition, Declaration and Prototype 
- Right click in the File WIndow, then click < ShowDefinition > to go to any object’s definition. 

- Right click in the File Window, then click < ShowDeclaration > to go to any object’s nearest declaration. 

- Place the cursor on a function name and click Goto→Prototypes to view a function’s prototype 

16. Perfect pair match 
When the cursor is at one of: (, [, {, /* and you click , the cursor moves to the corresponding    ),  ],  },  
*/   and vice versa. 

When matching braces, i.e. { and }, it is not necessary to place the cursor exactly at the brace.  

You can place the cursor anywhere on the line  

17. From a #if, #ifdef to matching #else, #endif, 
and vice-versa 

When the cursor is on a #if, #ifdef, #ifndef, click  to go to the matching #else, #elif or #endif. 

18. Viewing undeclared object Click on  to move the cursor downward to an occurrence of an object that is undeclared and not 
#defined either.  

19. Viewing unused object Clicking on  moves the cursor to the declaration of a local object that has not been used in the 
program. 

20. Viewing unmatched braces Click on Goto Find Errors Unmatched else, (, /* etc to move the cursor downward  

- to an unmatched brace i.e. “{“ or ”}”,  

- an unmatched comment delimiter i.e. “/*” or “*/”, or, 

- an unmatched “else” i.e. an “else” for which there is no “if”. 

21. Viewing syntax errors Clicking on Goto Find Errors Next Syntax Error moves the cursor downward to the next Syntactically 
Incorrect C/C++ sentence (if one is present).  

With this operation you can find syntax errors in a program (even without having to compile it) 

22. Outline Margin 
Click Tools→ Show Fold Level Margin to view the Outline Margin for every function within the file. 

- Click on ‘-‘ to collapse the current level in the function. 

- Click on ‘+’ to expand a level in the function. 

- Right click on ‘+’ to expand all levels under the current level. 
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8. Rich Trees                                                              

Rich Trees are call-trees or caller-trees where each function-node contains additional information for easy browsing and understanding of project code. 

1.  Create a Rich Tree 1. Create the desired Call-tree or Caller-tree 

2. Click < Search in Tree >  in the Tree window toolbar to open the Search in Tree dialog. 

3. In the Enable Display card, select the additional information that should be shown with each function node. 

4. Click < Apply > 

5. Also use the "Object Search" card to search for specific data objects and display them in the relevant tree 
nodes 

2.  The “Search in Tree” dialog 
Click the < Search in Tree >  in the Tree Window toolbar to view the “Search in Tree dialog”.  

 

 The Enable Display card Use this card to: 

− Enable/disable information that is displayed alongside each node 

 The Highlight Occurrences card Use this card to: 

− Select the criterion by which other occurrences of a node are highlighted  

 The Object Search card In this card,  

1. Specify the data object or struct name, etc 

2. Find in what functions the data object is used  -   by clicking < Search > or < Search All > 

 The Advanced Search card Using this card, you can: 

− find the next occurrence of a function in the tree.  

− find the next function used from a specific file. 

− use the "history list" to search for a particular object, struct, class, type or #define  

− search for a string in all the text that is being displayed in the tree-nodes..  

3.  Attach information to tree nodes Use the “Enable Display” card in the “Search in Tree” dialog 

 View parameters of functions Select “Function Parameter List”;   click < Apply >. 

 View stack depth at each node Select “Stack Size”;   click < Apply >. 
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 File Names where Functions are defined Select “File Names”;   click < Apply >.  

 Attach Comments to tree nodes At each tree-node,  view the comment associated with the function call: 

Select "Associated Comment ";   click < Apply >. 

 Objects used by functions Select “Object Name”;   click < Apply >. 

Use the "Object Search" card to search for specific data objects and display them in the relevant tree nodes 

4.  Which functions use a category of objects  Use the "Object Search" card  of the Search in Tree dialog 

 View list of globals used by each 
function 

− Set "Type of Object" to <Globals>  

− Set "Select From"  to  <Any Global>.       

At this point, "Object Name" contains < Any Global >  

− Click < Search > 

 List of Structures used by each function  − Set "Type of Object" to <Structures/Unions> 

− Set  "Select From"  to  <Any Structure/Any Union>.      

Now "Object Name" contains < Any Structure/Any Union >. 

− Click < Search > 

 Which members of a Structure are used 
by the functions 

− Set "Type of Object" to < Structures/Unions >  

− In  "Select From", select the name of the structure you are interested in 

At this point, "Object Name" contains the name of the structure 

− From ‘Members’  Click on the dot or arrow i.e. “.” or “->” 

− Set  "Select From"  to  <Any Member>. 

Now "Object Name" contains:  name-of-the-desired-structure.< Any Member > 

− Click < Search > 

5.  Which functions use a specific object : Use the "Object Search" card  of the Search in Tree dialog 
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 Which functions use a specific global − Set "Type of Object" to <Globals> 

− In  "Select From",  use the drop-down list to select the name of the global variable you are interested in 

Now "Object Name" contains the  name of the global variable 

− Click < Search > 

 Which functions use a specific member 
of a specific structure variable 

− Set "Type of Object" to < Structures/Unions >  

− In  "Select From", select the name of the structure variable you are interested in 

At this point, "Object Name" contains the name of the structure variable 

− From ‘Members’  Click on the dot or arrow i.e. “.” or “->” 

− In  "Select From", select the name of the specific member you are interested in 

Now "Object Name" contains:  name-of-the-desired-structure. name-of-the-desired-member 

− Click < Search > 

6.  Advanced Search In the “Advanced Search” card of the “Search in Tree” dialog: 

 Go to next node that is from a specific 
file 

− Select the “File Name” checkbox.  (the "Search String" check box should be OFF) 

− Use the drop-down list to select the filename you are interested in. 

− Click < Search > to find the next tree node that is from the selected file; Click < Search All > to find all 
nodes that are from the selected file. 

 Go to the next node that uses a specific 
object 

− Select the “Object Name” checkbox. (the "Search String" check box should be OFF) 

− Use the history list to select the object you are interersted in. 

− Click < Search > to find the next node containing the object name; Click < Search All > to find all nodes 
containing a match for the selected object. 

 Search for a string in tree-nodes − Select the “Search String” checkbox. 

− Enter the name of the string you wish to search for. 

− Click < Search > to find the next node containing the string; Click < Search All > to find all nodes containing 
a match for the selected string. 

7.  Highlight other Occurrences Use the “Enable Display” card in the “Search in Tree” dialog 

 Highlight nodes that have the same 
function name as the current node 

Select “Function Name”;   click <Apply>.  
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 Highlight nodes that are from the same 
file as the current node 

Select “File Name”;   click <Apply>.  

 Highlight nodes that has the same 
object-name attached as the current 
node 

Select “Object Name”;   click <Apply>.  

8.  Single-click to go to the function-call A single click on a node in the Call-Tree: 

− moves the cursor to the first call of the function in the parent's code 

− Subsequent clicks will move the cursor to the next call of the function in the parent's code 

9.  View the DataFlow of the data object − Click to select a tree-node that has a data-object displayed alongside it  

− Right-click anywhere in the Tree Window, then click < DataFlow for the Current Object > in the pop-up 
menu.  

10.  Filtering the tree After searching for a specific function in the tree, or when information is attached to the tree nodes, you can filter 
the tree so that only the nodes of interest are visible and the rest  of the tree becomes hidden. 

 View only the nodes that have objects After you search for an object and, as a result, that object is displayed alongside a few nodes in the tree: 

− Right click anywhere in the Tree Window. 

− Click < Show All Paths for Object >. 

Now only the sub-trees that contain the nodes-with-objects are visible, the rest of the tree becomes hidden. 

 View nodes that are from a specific file After you enable display of filenames, so that filenames are displayed alongside the tree-nodes: 

1. Select a node that contains the filename of interest. 

2. Right click anywhere in the Tree Window. 

3. Click < Show All Paths for Filename >. 

Now the sub-trees that contain the nodes-with-filename of interest are visible, the rest of the tree becomes 
hidden. 

 Search ALL  How "Search ALL" works:   Crystal will search to find all the nodes based on the search criterion.  

If any unexpanded parts of the tree contain search-matches, those parts will be automatically expanded. 

Only the sub-trees that contain search-matches remain visible, the rest of the tree becomes hidden. 
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 Show Whole Tree When a few sub-trees are visible and the rest of the tree is hidden, new searches and a few other operations 
can not be performed.   

To display the whole tree again:  

− Right click anywhere in the Tree Window. 

− Click < Show Whole Tree >. 
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9. Data Flow 

1. Create a DataFlow − Place the cursor on an object name in the file window. 

− Click on the < Create DataFlow >  in the toolbar. 

 What does DataFlow show? − The statements that use the data object,   the function-calls that take the data object as an argument 

− The control flow around the use of  data object 

 
DataFlow enables you to: 

− Quickly find all the functions that use the data object,  

− How they use the data object – get a complete view of data use 

− When passed as an argument, expand the function-call  - to view how it is used in the called function 

− With the graphical view, you can understand and remember much faster. 

2. DataFlow of a local A local variable is known only within a function.  

− When you create the DataFlow of a local variable, you will see how it is used in the current function. 

− When passed as an argument,  expand the function-call  - to view how it is used in the called function 

3. DataFlow of a global A global variable is visible to more than one function:. 

− In the DataFlow for a global,  you will see all the functions where the global is used. 

− Double-click and expand any of those functions to view the use of the global in that function. 

4. Dataflow of instances of a struct  DataFlow of a struct member in all the instances of the struct 

− Go to the member declaration and place the cursor on the member's name. 

− Click on the < Create DataFlow >  in the toolbar 

 Dataflow of an instance of a struct  DataFlow of a struct member in a particluar instance of the struct 

− Go to the code where it is used as member of that particular instance.  

−  Place the cursor on the member's name. 

− Click on the < Create DataFlow > in the toolbar 
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 Dataflow of all instances of a struct DataFlow of all instances of a struct 

− Place the cursor on the structure name i.e. the struct tag. 

− Click on the < Create DataFlow > in the toolbar 

5. Expand function-call in a DataFlow The presence of a function-call involving the data object is indicated by the  icon above the symbol. 

− Double-click on a symbol that contains a function call.  

The expansion is inserted just before the function call. 

 Collapse an expansion Double-click on the start symbol of the expansion 

6. View the code covered by miniature symbols − Click on miniature symbols and view the code covered by them. 

 Scroll highlighted code − Click the < Scroll Code Up >  and < Scroll Code Down >  in the Flowchart window toolbar 

7. Easily navigate to many functions in many 
files 

Click on a flowchart symbol and view the corresponding code in the Source File 

− Click on the symbol containing “Tracking: ….”  to go to the start of the function in file window. 

− In a DataFlow expansion,  click on the start symbol to view the function-call in the file window  

8. View the CallStack When you expand function-calls in a DataFlow, often you have a sequence of DataFlows that are nested in one 
another: 

To view the sequence of functions that brought you to a nested expansion: 

− Right-click in any symbol in the nested expansion  

− Select < Function Call Stack > in the pop-up menu  

Now you can see the full call stack. 

− Click on a function’s-name in the call-stack to go to its expansion 

9. View the function’s full flowchart  − Click on any symbol in the DataFlow so that the corresponding code is highlighted in the File Window.  

− Click  in the main toolbar at the top.  

 Go back to DataFlow To go back to the DataFlow: 

− Click < Back to Flowchart >  in the Flowchart toolbar 
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10. Call Flow 

1. Create a CallFlow − Place the cursor anywhere in the function. 

− Click the < Create CallFlow >  in the toolbar. 

2. What do you get with the CallFlow You get a simplified view of the function. You can easily see: 

− the functions called in that function 

− the control flow of the function 

3. View the code covered by miniature symbols − Click on miniature symbols and view the code covered by them. 

 Scroll highlighted code 
− Click the < Scroll Code Up >  and < Scroll Code Down > . 

4. CallFlow enables you to: − Make a fast attack on the current function and its called-functions  

− Understand a function's logic in detail  

5. Expand function-calls in a CallFlow In CallFlow, the presence of a function-call is indicated by the  icon above the symbol. 

− Double-click on a symbol that contains a function call.  

The expansion is inserted just before the function call. 

 
Collapse an expansion − Double-click on the start symbol of the expansion 

6. 

 

Easily navigate to many functions in many 
files 

Click on a flowchart symbol and view the corresponding code in the Source File 

− Click on the symbol containing “Tracking: ….”  to go to the start of the function in file window. 

− In a CallFlow expansion,  click on the start symbol to view the function-call in the file window  
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7. View the CallStack When you expand function-calls in a CallFlow, often you have a sequence of CallFlows that are nested in one 
another: 

To view the sequence of functions that brought you to a nested expansion: 

− Right-click in any symbol in the nested expansion  

− Select < Function Call Stack > in the pop-up menu  

Now you can see the full call stack. 

− Click on a function’s-name in the call-stack to go to its expansion 

8. View the function’s full flowchart  
− Click on any symbol in the CallFlow so that the corresponding code is highlighted in the File Window.  

− Click  in the main toolbar at the top.  

 
Go back to CallFlow To go back to the CallFlow: 

− Click < Back to Flowchart >  in the Flowchart toolbar 
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11. Data-Dependency Trees 

1. Create a Data-Dependency Tree  Place the cursor on any data-object.  

− Click <Create Data Dependency Tree>  icon in the toolbar. 

 Data-Dependency Tree of a global Place the cursor on a global and create it’s data-dependency tree. 

The data-dependency tree of a global variable will contain 

− All occurrences where the global variable is being modified 

− If a global variable is being passed as a function argument, then the name of the function. 

− All modified occurrences of the objects modifying the global variable; and so on. 

 Data-Dependency Tree of a local Place the cursor on a local and create it’s data-dependency tree. 

 Data-Dependency Tree of a member Place the cursor on the structure member and create it’s data-dependency tree. 

The data-dependency tree will contain: 

− All modified occurrences of the member. 

− All modified occurrences of  the objects modifying the member 

− If the member is being passed as an argument, then the name of the function. 

2. Expand the Data-Dependency tree Expand the nodes of the Data-dependency tree by clicking on “+” 

 Expand the whole Tree To fully expand the sub-tree under the current node,  

Right click anywhere in the Tree window;    Click < Expand Full > 

3. Navigating Double-click on any node in the Data-Dependency tree to go to the corresponding source code line. 
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4. Node Prefixes − A    - indicates that the node is an array  

− D    - indicates that the node is a defined constant  

− E    - indicates that the node is an enum variable 

− F    - indicates that the node is a function 

− G    - indicates that the node is a global 

− M    - indicates that the node is structure or union member 

− P    - indicates that the node is a pointer 

− T    - indicates that the node is a typedef 

− EC -  indicates that the node is an enum constant 

− FA  - indicates that the node is a function argument 

− FP -  indicates that the node is pointer to function 

− GA - indicates that the node is a global array 

− MP - indicates that the node is a member pointer 

− +     - indicates that the node is EXAPANDALBLE 

- -      - indicates that the node is EXPANDED 

- *      - indicates that the node is RECURSIVE 

5. The “Search in Tree” dialog Click the < Search in Tree >  in the Tree Window toolbar to view the “Search in Tree dialog”.  

 

 The Enable Display card Use this card to: 

− Enable/disable information that is displayed alongside each node 

 The Highlight occurrences card Use this card to: 

− Select the criterion by which other occurrences of a node are highlighted  

 The Advanced Search card Using this card, you can: 

− find the next occurrence of an object name  

− find the next object  used from a specific file. 

− find the next occurrence of a function in the tree.  

− use the "history list" to search for a particular object, struct, class, type or #define  

− search for a string in all the text that is being displayed in the tree-nodes..  
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6. 

 

Attach information to tree nodes Each node in the data-dependency tree shows   

1. Name of data object    

2. function name    

3. file name    

4. Line number 

Use the “Enable Display” card in the “Search in Tree” dialog 

 View function names in which objects are 
used 

Select “Function Name”;   click < Apply >. 

 File Names where Objects are used Select “File Names”;   click < Apply >.  

 Attach Comments to tree nodes At each tree-node,  view the comment associated with the function call: 

Select "Associated Comment ";   click < Apply >. 

 Objects used by functions Select “Object Name”;   click < Apply >. 

Use the "Object Search" card to search for specific data objects and display them in the relevant tree nodes 

7. Search for a Object in the Data Dependency 
Tree 

Use the “Advanced Search” card of the “Search in Tree” dialog 

8. To view the occurrence of an object deep in 
the Tree 

− Select the node corresponding to the object 

− Right click in the tree window, and, then click < Show Path >. Now you can see the 
path from the root to the node for the object. 
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12. Generating HTML Documentation 

1. Generate  HTML Documentation − Click Project→Create HTML Document  

− In The HTML Documenter Settings Dialog, select the desired options.  

− Click < OK > 

Crystal C/C++ will begin creating the HTML documentation for the current project.  

When the documentation completes:  

− Click < OK > - the default document will be displayed in your browser. 

 Open HTML Document To Open the HTML documentation for the current project: 

− Click Project→Open HTML Document 

 Including Project Specific information To include project notes, comments, development history, on any specific project related content in the 
documentation: 

− Click Project→Open Notes – to open the project notes file 

− Enter the content to be included as part of documentation in the project notes file and save it. 

− Now create the documentation.  

 Configuring the HTML Documentation 
Content 

Use the HTML Documenter Settings Dialog to configure the contents of the HTML documentation. 

2. HTML Documentation provides − Team-wide viewing of source code 

− Publish source code on internet and CD-ROM 

− Full source code browsing in the absence of an IDE. 

 HTML Documents also provide − Comprehensive information – including flowcharts, trees, code-metrics, cross-reference, etc 

− Easy to browse, easy to comprehend, wide code coverage 

− Ideal platform to discuss designs with clients and global teams – without actually transferring source code. 

3. Contents of Crystal HTML Documents − File documentation  

− File Include-tree  

− Source code listing - beautified and syntax-highlighted.  

− Flowcharts for all-functions  

− Call-tree, caller-tree, etc  

− Code Metrics  

− Cross-reference  
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− Static Check documentation  

4. HTML Documenter settings dialog Configure the contents of the documents here. 

 Specifying the documentation folder − Specify the path where the documentation is to be created in “Path for Documents”. 

 Changing the documentation Title − Enter the “Documentation Title” in the Report Title panel 

 Attaching a  logo to the documentation − Browse and choose the LOGO file for the documentation. 

 Enable Code-metrics  Under the General section: 

− Check ‘Enable Code Metrics’ to include code metrics as part of documentation 

 Include source code listing In the Source Code Section: 

− Check ‘Source Code Listing’ - the formatted source code for each file will to be included in the 
documentation.  

 Include static-check reports In the Static Check Section: 

− Select "Enable Static Checker" to static check each project file When selected, the ‘MISRA C’ static 
checking report for the project will be part of the project.  

 Include function flowcharts  In the Flowcharts section: 

− Check Enable Flowchart creation to include flowcharts for all project functions as part of the document. 

− Check – Thumbnails with Height and Width  

− Choose the type of the flowchart with the level of the detail. 

 Include various types of trees  Use the Trees section to select the types of trees to be included as part of the HTML documentation. You can 
select from  

5. Browsing in HTML documentation The home page for each documentation set is “default.html”. View the project summary here. 

Then, click Project Overview→Browse Tree to view the Project tree. Use it to navigate in the documentation. 

 Project Browse Tree − Expand the nodes to of the tree,  

 File Documentation View a file’s individual documentation. Use 

− File Report Tree 

− Documentation 

− Source Code Listing 
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 Code Metrics The HTML documentation contains the following Volume Metrics: 

− Project Metrics 

− File Metrics 

− Function Metrics 

You can also view the following Complexity Metrics: 

− Halstead’s Complexity Metrics 

− McCabe’s Complexity Metrics 

 Cross Reference View the list of all globals in the project, along with where the object has been defined and used. 

 Static Check Report View the static check report – on a per file or a per rule basis. 

6. Documentation Menus Please view the Help contents. ( Html Documentation→Menus… ) 
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13. Static Checking 

1. Static Checking Report for  a Project To static-check a project, click Project→Create Static Checker Report. 

In the Static-checker dialog, select: 

− The Rule Type from the drop-down list  

− The rules to be checked under the Rule Type  

− The output report format.  

− Click < OK >. 

The Static Checker progress meter will be displayed 

As soon as the report generation is complete, the results will be displayed in the selected format. 

 Static Checking a File To static-check a file, click Tools→ Create Static Checker Report. 

 Which Static Checking standards are 
supported 

You can choose from: 

− MisraRule1998 - for MISRA-C:1998  

− MisraRule2004 - for MISRA-C:2004  

2. Select the Rules to Check Before you begin static-checking,   

− Select  the rules to be checked 

− Unselect the rules you want to ignore 

3. The Static Check dialog Use this dialog and control the generation of static checking reports. 

 Settings Use the settings menu to Import or Export a pre-defined set of rules to be checked. 

 Rule Type and Rules List Chose the standard to check and then select the rules to check/ignore from the rules list 

 General Settings While reporting violations, if Crystal REVS find's a known violation that has been marked in the code for not to 

be reported, it will not be reported in the output if 'Report all violations ignoring the embedded pragmas' is 

unchecked. 
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 Output formats The result of a static check violations test can be: 

− Viewed in the Output Window within Crystal C/C++. You can navigate, view and correct these violations 

− Viewed as HTML reports generated in a specified folder. These HTML reports can be given to the other 
members of a development team to fix the various violations. 

4. Viewing the Report You can view a static report in the “Static Checker” tab of the output window. 

5. Excluding known violations from being 
reported 

For violations which are known to exist in a project, you may want to suppress reporting them every time.  

To do so, mark such violations in the source code. 

 Suppressing violations for the whole file To suppress reporting rules 5.5 and 5.6 of MISRA 2004 

− In the beginning of the file insert /*#pragma disable( MISRA2004, 5.5, 5.6 )*/ 

 Suppressing violations for a given 
range 

To suppress reporting rules 5.5 and 5.6 of MISRA 2004 

− In the beginning of the range insert /*#pragma disable( MISRA2004, 5.5, 5.6 )*/ 

− In the end  of the range for ignoring 5.5, insert /*#pragma enable( MISRA2004, 5.5 )*/ 

− In the end  of the range for ignoring 5.6, insert /*#pragma enable( MISRA2004, 5.6 )*/ 

 To add a reason while suppressing a 
violation 

To suppress reporting rules 45:2 of MISRA 1998 

− In the beginning of the range insert  

/*#pragma disable( MISRA1998, 45.2:”This rules has been suppressed.” )*/ 

You can use any string of your choice after the colon ’:’ 

6. Static Check Reports and HTML 
Documentation 

The static-check report can be part of the HTML documentation. 

To include the static check report:  

− Click Project→Create HTML document  

− Enable Static Checker  

7. Static Check Reports and Command Line 
mode 

The static-check report can also be generated in the command line mode.  

Please view the Help contents. ( Static Checking→ … ) 
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14. Comment Trail 

1. Software Change Report The Comment Trail Marker report is the software change report.  

All software changes under a single Change ID are grouped and tracked together. 

2. Creating a Comment Trail Marker − Click Insert→Comment Trail Marker→New Comment Trail Marker and create one. 

− Click < Save > to save the created Comment Trail Marker. 

3. Comment Trail Marker format A typical comment trail marker looks as follows 

CTM: ListOverflow  JohnD  11/24/2009: pointer increment was missing here ENDCTM 

4. Inserting Comment Trail Markers − Click Insert→Comment Trail Marker→ListOverflow 

You can select any Comment Trail Marker of your choice. 

5. Viewing Comment Trail Marker Report − Click Tools→Comment Trail Marker Report→ListOverflow to view the list of all comment trail markers under 
the ID ListOverflow 

− The Comment Trail Marker report will be displayed in the output window in the Reports card.. 

6. View a list of all Comment Trail Markers in 
the project 

In the Browse Window,  

− View the Prj Browse Card 

− Click and expand the node “Comment Trail Markers” 

− Click on a Comment Trail Marker to view it’s report. 

7. Deleting Comment Trail Markers To remove occurrences of a Comment Trail Marker from the project 

− Click Tools→Remove Comment Trail Marker 

Alternately, you can right click on a Comment Trail Marker in the Prj Browse window, or, use the < Remove > 
icon in the Report window. 
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15. State Transition Diagrams 

1. State Machine in a flowchart − A rectangular border is drawn around the sequence of statements that correspond to a state.  

− One or more statements in a state can trigger a transition to another state. A transition is shown by drawing 
an arrow from that statement to the border of destination state.  

− You can attach a comment or a note to a transition arrow. 

2. State Machines as a switch-case Often a state machine is coded in the form of a switch-case 

 Expanding and collapsing a switch − Double-click on a switch symbol to collapse the whole switch to a high-level symbol.  

− Right-click on the high-level symbol, then click < Expand Symbol > in the pop-up menu. The switch will be 
fully expanded.  

− Double-click on the high-level symbol to expand the switch by two levels  

3. Create a State Transition – process To create a State Transition Diagram: 

− Enclose each state in a rectangular border 

− Create a State Transition 

− Change the routing of a State Transition 

− Provide a comment to a State Transition 

 Enclose each state n a rectangular 
border 

To mark only a few cases as states : 

− Right-click on the desired case symbol.  

− Click : State Diagrams→Mark as State  

In general, you can also right-click on a for, while, do, if symbol and mark the whole body as a state. 

You can also mark all cases as a state in one go.  

 Create a State Transition − Identify statement which causes a transition to another state (trigger statement).  

− Right-click in the trigger statement symbol, then click: State Diagrams→Create Transition.  

− In the "Flowchart State Transition" dialog box, specify the resulting state.  

− Then, provide a comment that will be attached to the transition arrow 
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 Change the routing of a State 
Transition 

− Right-click on the symbol which contains the trigger statement.  

− Click: State Diagrams→Transition Route  

− In the "Flowchart Transition Route" dialog, change the "From" and "To" settings. 

 Provide a comment to a State 
Transition 

− Right-click in the symbol that contains the trigger statement.  

− In the pop-up menu, click : State Diagrams→Add Comment to Transition  

4. Modifying the comment in a State Transition − Right-click in the comment attached to the State Transition.  

− Click : State Diagrams→Transition Comment Properties  

− Provide the new comment there! 

5. Display the State Transition with a desired 
detail level 

− Right-click on the switch symbol, then click: State Diagrams→Collapse All Cases.  

− Double-click in the switch symbol to collapse the switch.  

− Double-click in the high-level symbol. The switch is expanded to two-levels of detail.  

− Double-click in the switch symbol to collapse the switch.  

− Right-click in the switch symbol, then click Expand Symbol. You get a fully expanded State Transition 
Diagram.  

6. To save the State Transition Diagram To save the State Transition Diagram : 

− Right-click anywhere in the flowchart window.  

− In the pop-up menu, click: State Diagrams→Save & Close Flowchart.  



 2010  SGV Software Automation Research Corp.  SGV SARC, Crystal REVS, SGV SARC logo are trademarks of  SGV Software Automation Research Corp. All rights reserved. 
 

42 

 

16. Edit Operations 

1. Insert { } around single statements In a file,   

− Click Insert→Insert { } around single statements 

Crystal C/C++ scans the file for all condition statements like if( ), for( ; ; ), while( ), do( ), etc which are not 
followed by a pair of ‘{ }’. 

It inserts a ‘{‘ immediately after the condition statement;  

It inserts a ‘}’ immediately after the following statement.  

2. Swap YES and NO parts of an if..else ,, 
statement 

− Place the cursor on an “if( ) statement” or an “else” 

− Click Edit→Logic Change→Swap the parts of if_else_statement 

3. Change do while to while loop − Place the cursor on a “do statement”  

− Click Edit→Logic Change→Change do_while loop to while loop 

4. Change while loop to do while loop − Place the cursor on a “while( ) statement”  

− Click Edit→Logic Change→Change while loop to do..while loop 

5. Rematch Braces − Place the cursor within a function 

− Click Edit→Logic Change→Rematch Braces 

6. UnComment To uncomment: 

− Place the cursor within a comment block /*  */ 

− Click Edit→Uncomment 

7. Comment Out with /* */ − Select a block of text to be commented. 

− Right click, then click Comment Out using /*  */ 

8. Comment Out with // − Select a block of text to be commented. 

− Right click, then click Comment Out using // 

9. Condition Out / Code out − Select the block of code to be coded out 

− Right click, then click Condition out 
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10. Enclose in { }  − Select the lines to be enclosed in { }  

− Right click, then click Enclose in { } 

11. Enclose in ( ) − Select the condition to be enclosed in ( )  

− Right click, then click Enclose in ( ) 

12. Delete a pair of { }. ( ), [ ], etc − Place the cursor within the pair of { }, ( ), [ ], etc that you wish to remove 

− Click the < DelPair> button 

13. Move Comments to right If comments are sprinkled among the statements, you can get an uninterrupted view of the code: 

− Click Edit → Move Comments → Move All Comments to Comment-field. 
 

14. Shift a statement Up or Down In the Tokens Panel, 

− Click <MvSnt ↑> to move the current sentence upward 

− Click <MvSnt ↓> to move the current sentence downward 

15. Select the whole function, a while loop, a 
whole case, etc 

Place the cursor in the desired function, or statement 

− Click on the Select Block icon on the main toolbar. 

− Choose from the drop-down list. 

16. Multiple Clipboards Click Edit→Paste→Paste # N to display Multiple Clipboard. 
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17. Formatting for improved readability 

1. Crystal C/C++ Formatter − Crystal Flow's formatter is parser-based. It does a lot more than a formatter that uses lexical analysis only. 

− Alignment of type specifiers, declarators among consecutive declarations 

− Alignment of assignment operators among consecutive assignment statements 

− Formatting of long expressions that take up more than one line - based on precedence of operators 

− Proper formatting of macro definitions that contain many statements 

− Maintains a comment-field to the right for easy readability 

2. Formatting files in Crystal C/C++ When Crystal C/C++ opens a file for the first time: 

− It uses the current format settings to format the file and saves the format settings on a per file basis. 

− When you open the file again, the saved format settings are used for that file. 

3. To modify Format settings Click  Tools → Options → Environment → File Window → Format Settings 

− Set the Indent and Tab Size, etc 

− Change the Code Formatting Style 

− Change the Comment Formatting Style 

− Selectively disable formatting of code or comments. 

4. To apply the modified format setting To apply the new settings to a file that is currently open: 

− Click File→Refresh Current File. 

(Until you Refresh the file, your changes will not be applied to the current file) 

To apply the new settings to all files in the project 

− Click Project→Reparse Project Files→All 

(Until you Reparse the project, your changes will not be applied to the whole project) 

5. To disable automatic formatting  Click  Tools → Options → Environment → File Window → Format Settings 

− In the Format Mode,  select None. 

− Apply the modified settings to the files as described above. 
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18. Batch Operations 

1. Batch Output of Flowcharts − Click BatchOutput→Flowcharts for Project  

− In the displayed dialog, select the type of flowchart to be output. 

− Select the level of flowchart which should be output 

− Select the target format – Visio, Image, etc 

− Select if you want to print the flowcharts too. 

− Select the folder in which the output should be created. 

− Click < OK > 

2. Batch Output of Trees − Click BatchOutput→Graphs for Project  

− In the displayed dialog, select the different trees you want to be output. 

− Select the folder in which the various trees should be output. 

− Click < OK > 

3. Batch Printing Files − Click BatchOutput→Files for Project  

− Follow the instructions on the dialog and click < OK > 

4. Batch Output Files, Flowcharts and Trees − Click BatchOutput→All to output Files, Flowcharts and Trees in a single go. 
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19. Miscellaneous Operations 

1. Preprocessing a File To preprocess a file: 

− Click Tools→Preprocess.  

Crystal FLOW or REVS preprocess the file and displays the preprocessed output in a different file with the same 
name and “pre” suffixed in the extension.  

2. Code Metrics Reports To generate the various Code Metrics Report,  

− Click Project→Generate Code Metrics  

In the ‘Code Metrics’ dialog,  

− Select the target folder 

− Select the output format 

− Set the color coding – for high, medium and low values 

− Click < OK >  

Please view the Help contents. (Html Documentation->Browsing in the ….->Code Metrics) 

3. Publish Source Code − Click Project→Publish Source Code  

− In the ‘Source Code Publisher’ dialog, browse and select the destination folder 

− Click < OK > 

4. Compile a File To Compile the current file: 

− Click Tools→Compile  

The errors and warning messages are displayed in the output window under the compile tab. 

To select your compiler, settings, preprocessor directives, etc use the Options menu. 

 Compile All  To compile all files: 

− Click Tools→Compile All. The Compile Files dialog is displayed. 

− Select the files to be compiled.  

− Click < Compile > 

The errors and warning messages are displayed in the output window under the compile tab. 

5. Running Batch Files You can run any batch file from the Crystal C/C++ environment. To run a batch file: 

− Click Tools→Run User Batch File.  

− In the dialog, specify the Batch File to be executed 

− Click < Run >  
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20. Trouble Shooting 

For any support/trouble shooting/FAQ or any other queries, contact the 24x7 customer care at support@sgvsarc.com 
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